Retool Mobile apps authentication failure "mismatched xsrf token"

I am trying to run my apps on retool mobile. They have been working pretty consistently for weeks. Now all My mobile apps come up without data because I am getting an authentication failure.

"Mismatched xsrf token"

I dont know what to do here. I have tried logging out and back in, but the issue persists. The apps work fine when I am running from a desktop browser.

This is still an issue for me. My apps are completely unusable on mobile. This is pretty critical for me.

What platform are you on, and have you upgraded to the most recent App Store app?

I am on android 13. I have the most recent retool app from google play store.

Unfortunately we can't repro, but we did have some strange issues with Samsung devices and cookies in December. It's possible your issue is related.

Do you mind testing our 2 most recent app store versions to determine if this is a recent regression?

12/15 release: com.retool.retool 12-15-2023 (1966).apk - Google Drive

12/1 release: com.retool.retool 12-01-2023 (1946).apk - Google Drive

my apps work in version 1946. I have not tried 1966 yet.

Can you share a video or screenshot of the "Mismatched xsrf token" error?

I have just tested and my apps also work in 1966.

1 Like

Same problem here! Any solutions yet? I have around 20 users and its messy to coordinate reinstall the app with all

@pedrowach can you share more details on the issues you're seeing?

  • Are every one of the users (including yourself) unable to log in? Is the issue consistent?
  • What kind of devices do they have?
  • How long has the issue been happening?
  • Have they ever been able to log in successfully?
  • You mentioned "reinstall the app", can you share more about that process and what it fixes?
  1. Most of the user with Android devices.
    The problem is NOT when they log into the app, is when the app run a resource query (my case is postgreSQL query). The queries fail so there is no data, the problem that the console shows says the following:

No, is not consistent. Sometimes happens, other times not. Is unpredictable.
2.- Just Android , Galaxy A14 G5
3.-Since first week of January 2024
4.-Not a problem with log in.
5.- To sovle this issue. I've been making them to unistall the Playstore app AND install the apk version. BUT the apk version is showing the same problem

I am currently experiencing the same issue on a tablet, on a Galaxy Tab 8 (Android 14). It appears to be device-specific as I can run the thing just fine from my mobile, Galaxy S10e (Android 12). Retool app is up to date on all devices. It doesn't appear to be app-specific as running other apps with other SQL queries, gives me the same error. It is a new phenomenon as the thing was working fine as of Friday 22nd March. Today I saw the error, did the log out/in, updated Retool from the Play Store (it wasn't up to date), some more log out/in, still seeing the same error and same result: app cannot be used because it cannot acquire any of the data it needs.

Hello, I've seen similar issues identified in another post but not resolved.
We have some Zebra TC26 devices running retool mobile and we now have two that are experiencing an error in pulling any resources from the Retool Databases (Postgres).

Upon checking, the error that comes up is:
Authentication failure. Mismatched xsrf token

I have, as suggested in this post, attempted to Log out and back in, reinstall the app and finally clear the cookies in chrome on the device.

None of these actions have remedied the issue.

Logging in as a different user also causes the same issue but all users are fine if swapped to another app.

All running on 3.59.0

The previous ticket appears to be closed without resolving this issue so I'm reopening it.

1 Like

Hi @Harvey_Francis, welcome to the forum! :wave:

The topic we linked is this same one, could you add a link to the other one where we suggested logging out and back in?

I found this one where a customer reported Zebra devices are crashing after login, are you experiencing the same issue?

On the other hand:

This other app is also being open on the Zebra devices and causing no issues?

Thank you in advanve!

Are we having the same issue if we try to access the same app as an admin on Mobile?

We just had the same issue with one of our Zebra TC22 devices (just one out of 8 devices).

In the debugging console, I could see the error:
Authentication failure. Mismatched xsrf token

We tried the following (which did not work):

  • Restarting app
  • Restarting device
  • Logging out and back in

After finding this post, we re-installed the app and it worked again.

Hi @cjschmedt, thank you for sharing your experience! :slightly_smiling_face: