Android mobile apps suddenly not working

That issue was fixed at the time of that post but now all of our android users are unable to login at all. Just blank white page after login.

@stevenhdsdoor Thank you for reporting! Are you seeing something like this by any chance? Or something else?

Doesn't even show setting up app just completely blank after login.

This is happening with the login link not sure if that has something to do with it.

Cannot press anything or do anything no swiping nothing. Blank white.

@stevenhdsdoor A few debugging questions:

  • When was the last time this exact flow worked?
  • Is this affecting all users on Android, or just some?
  • For those users this is broken for, does the same flow work for them on iOS?
  • Is it possible to open the Retool mobile app from your home screen, log in using the "Log in to Retool" button, then navigate into an app from the apps list?

Lastly, can you share a video of the broken behavior starting with tapping the login link you referenced?

Apple users are unaffected, all of our android users are down.

Unsure of when this started, at least a few days. We don't use the mobile app super often. When the previous bug in this thread was fixed we all checked and it was working again so it died somewhere in-between the fix was pushed for that issue and now.

App list doesnt exist its a blank white screen.

I have a screen recording PM me an email to send it to.

We've been seeing the same symptoms for a little over a month. I have a support ticket going, but we've been unable to find anything that works. The login process seems to work (and Audit Logs on the web console show a successful login), but the mobile app just flips back to a blank white screen. We've tried uninstall/reinstalls, cache/storage clearing, reboots, but can't seem to get it to work.
I believe there was an update on the mobile app where the authentication used to stay within the app, and now it redirects out to a web login. I don't have any screen shots/recordings of this, but I believe that's when this started for our first user.

They have a loom from me showing the exact same thing. I've been emailing with braden about it.

Yall need to get some windows and samsung devices in the offices to test changes before pushing an update.

@Matt_N what kind of device are you using?

I have the same issue and I have a Samsung Galaxy Z Fold3.

We have two devices that are experiencing this right now - both are Samsung's. One is an S21, and the other is an S23.

Thanks for the reports all. Keep em coming. The more specific details on your device the better. So far it seems like this is an issue with a specific subset of Samsung devices. More data points always helpful.

Hi everyone, if you are experiencing this issue we have a temporary fixed APK build here: 1982.apk - Google Drive

You can download that file and install it as the Retool app on your Android phone. It should make it possible to log in.

I was able to test today with one of our Samsung phones that were having trouble, and the linked APK fixed the login problem. I'm working on getting a couple other users into the office to try it as well.

1 Like

Thanks @Matt_N, we're working on getting this fix out to the app stores as well.

Hey folks, the fixed Android app is now available on the Play Store. Let me know if you continue have mysterious login issues on Samsung devices.


Hi all,

we are also having issues with the login since a few days.
When we open the Retool App and login we get redirected to the retool desktop website and not the mobile app.
So we cannot use the mobile app anymore. We experience this on multiple phones, e.g. Samsung S21 and Motorola G54. We updated to the latest version of Retool and Chrome browser.

Is this the same issue or something else?

Same here!

We're having this on multiple iPads now too. Let me know if we should start a new thread, as this has been predominantly an Android problem, but on the iPads it logs into Retool web inside the credential popup window and never redirects back to the app after authentication.

Hey everyone! Looking into this with the mobile team now.

Around when did this start breaking for you all?