Trying to set up custom domain (and its not working)

I set up a custom domain for my retool app. I used the 3 IP addresses that it says to use in the retool docs on how to set up a custom domain. I saved them as A records as a subdomain to a domain that I already use. (ex. if my domain was, then my app should be Then I put my new domain into retool under settings as a custom domain. But I am getting a 404 response when I try to open the page. Can anyone offer any help?

Just trying to bounce this up - hoping to get a reply...

Hey Liora!

I'm sorry to hear about the difficulties you're facing with your custom domain setup. A few possibilities may be causing this issue.

First, after applying DNS changes, they could take up to 24 hours to propagate. This delay is normal and depends on the TTL setting on your DNS records. Though, given that you wrote in a week ago and it seems like you're still blocked, I assume we can skip this one.

Second, ensure your A records correctly map to Retool’s designated IP addresses. Though again, you confirmed that you already did this step.,,

As a note, wildcard DNS entries (*) should ideally be avoided, as they could be a security risk. Once the changes are in place, verify your settings in Retool under /settings/branding.

Adding a custom domain puts it in a temporary pending state for Retool to process HTTPS certificates and internal updates.

Your new login page should be <your_custom_domain>/auth/login, however, the old login path <your_subdomain> remains valid. To double check this step, what URL are you visiting when you get a 404?

For more detailed information, you can consult Retool's docs (though I assume you've read them already!):

Hi, thank you so much for your reply!
The first few things that you mentioned, I did already. The only thing that I didnt do - is changing the wildcard DNS settings. How would I change that?

I have tried visiting (my custom domain) and
both brought me to a 404 page.

I have read through all of your docs, I really could use some more help than what is offered there.

Thanks so much!

Just bouncing this up again. I would really appreciate it if you can answer me!!

Hey @Liora_Waxman, can you share what the Retool UI shows in the custom domain field? There should be a green check mark if the domain is verified.

Screenshot 2024-03-04 at 7.57.48 AM

Also curious what you are getting when you run the dig command that we share here?

@joeBumbaca I am also experiencing the same thing. Dig shows the IP's correctly but I get a red x saying the domain can't be verified.

Having the same issue even though dig give the correct IP address

Hey @tharkana_am Looks like we had an issue with the verification process, but it should be working now. Are you still seeing the error?

Yes... I have opened a new topic for this in here Looks like the issue still persist... not sure...
I checked now...still not working

Ok, it seems to be resolved for most users, but let me check on your instance specifically. Can you share the subdomain of your organization? Thanks!

I'm having this same issue with

Dig show DNS is good pointing to your IP, but retool says can't be verified. I set it up 3 days ago.

Hey @Nicholas-1 looks like that url goes to the Retool login page. If you refresh the settings page does it show that it's verified?