Changing custom domain breaks user invite links

Business plan.

months ago, we used a custom domain apps.trapezoidtech.io for Retool.
about a week ago, we changed to app.trapezoidtech.io, and it's been working fine after a few hours when the DNS A record change propagated.

now, i tried sending an invite to one of my other emails, and the Accept Invite button (and corresponding "try this in your browser" URL underneath) points to the old apps.trapezoidtech.io, which fails to load anything in the browser.

here are the steps to reproduce:

  1. in your admin/logged-in Retool account, go to Settings > Branding > Custom domain and change to a new value. wait a few hours/days to ensure everything is propagated.
  2. in a private browser window, use a new email from a domain you have no settings for (eg. default groups, auto-join, etc.) click the "Request access" button and see a "we've let them know you asked, wait for their approval" message
  3. from your admin/logged-in account, go to Retool > Settings > Users > "you have 1 user pending approval" > click Approve
  4. in the private browser window, go to your email inbox and click Accept Invite. you should see a "not found" error screen from the browser, and see the old domain in the address bar.
  5. in the email message to accept invitation, you should also see the old domain in the "click this link if you're having issues" URL

Hi @trz-justin-dev,

Are you still running into this issue? Reproducing now.

hey @AbbeyHernandez , well... this issue disappeared when i tried to recreate it for documenting the solution! It happened once and not again so it's elusive

Hmmm, very weird! I'll keep this thread open in case anyone else runs into the same problem. What retool version did you notice this on?