Struggling with linking custom domains from CloudFlare to the Branding section


We are trying to connect our retool to our domain but so far we haven't been successful doing so. I've followed the instructions as shown in here:

According to the Branding section, the domain has already being validated. However, whenever I access to the domain, it shows me a message that the website isn't working. I've been told that normally it can take up to 24 hours even 72 hours. So, we've waited 3 days and still nothing. We have even tried to enter to only to have the same message.

From the side of cloudflare, our setup looks as follows:

I'm not able to change the TTL, the only option defaults to auto so, I imagine it's only a matter waiting there. But I'm wondering, if I'm doing things correctly in here or if I'm missing something or if there's something else that might be preventing the website to show that I should be looking in more in depth or maybe I'm not understanding the purpose of the branding section.

I was trying the DNS, but currently I change to to see if that might change something.

Here's also an image of how the site shows as validated


Any help would be greatly appreciated.

I believe there's an issue with your DNS configuration, or it's been changed. Running a dig command similar to the one in the documentation results in A records pointed at different IP addresses than ours.

This may be due to the way cloudflare proxies work, but I'm not certain in that and you should reach out to them since it doesn't seem to be resolving to the IPs in the documentation


Thank you so much! I turned off the proxy option of cloudflare based on what you mentioned and decided to wait for a while too see if that worked and now it's up and running :grin:

1 Like