Error with upgrading account

Hi all,

I've paid to upgrade my self-hosted retool account to business but Retool still says "Granular access controls are not available in your plan.
Upgrade to create custom groups."

I've tried logging in/out, invalidating all sessions and logging back in. All with no luck.

Anyone know what might be going on here?


It may take a few hours for changes to self hosted plans to reflect on your instance. If you made the change recently, you can try manually updating your license key in settings > advanced > check key, which can force an update immediately.

ah I see. So the license key changes when you change the plan subscription? Then I would need to put the new/updated license key in the Dockerfile?

The key itself does not change. However, available features are encoded in the key, and your instance periodically fetches changes to the license status and available features.

Ah ok. I think I understand.

How does this then work if I were to run a self hosted retool on a closed network (without internet access).
Or is this not possible to do?

This is not possible on our normal plans. If offline deployment is required for your usecase, I would suggest reaching out to our sales team.

Are you saying that it would be only possible to do this with an Enterprise subscription?
The billing page implies that it should be possible on the business plan:

That section only applies to mobile apps, unfortunately. Constant internet access is required for the rest of the instance.

ah I see. So even with an Enterprise plan this would not be possible?

Also, do edits to user permissions, groups etc. take time to take effect on the self-hosted platform (cf. the cloud retool)?

It is a possibility on enterprise, you can reach out to learn more.

Edits on your local instance should be instant. Are you seeing otherwise?

ah ok. That is unforunate since the Enterprise plans are quite expensive! But good to know :slight_smile:

I am seeing otherwise. I made groups, changed permission to 'use' only for apps and those users still seem to have edit access

Make sure that you have updated the "all users" group app access level to "Define specific app access" as well, so that edit permissions aren't automatically inherited.

1 Like

ah yep that worked, thanks!