Public option not available after upgrading to Business (Self-hosted)

Hi all,

My retool instance isn't getting the features after upgrading to the business plan. Please advise!

Christopher Triolo

Also if it's helpful I have also been receiving this error when trying to save a page.

We are using my license key on's account.


I noticed that the screenshot you sent is from a self-hosted plan, but the business plan is only available on cloud. Can you confirm for me what account you are writing in about?

If you are writing in about the self-hosted plan it is likely you will need to do another license check which can be done by restarting your containers.

Whoops! Startup plan. My apologies.

I am now able to get previews of my apps, but I still get the "Your trial has ended!" notification when I try to edit any app.


The behavior you are seeing of being able to preview and not edit usually means either you still need to select a plan or we need to do another license check by restarting the containers. If you have confirmed that you have already paid and restarted the containers please let us know and we can keep digging into it!

Hi Lauren,

Thanks for the pointers. We just tried restarting the containers again and no luck. We confirmed my license key is there and I am in fact paying for the startup plan.

Any other pointers?


Thanks for letting us know! Can you confirm the last four digits of your license key so I can make sure I am looking at the right instance?



Thank you for confirming that for me! Can I ask what version you are currently on? I would recommend at least being on 2.74. It looks like there have been a couple similar bugs on earlier versions.