Bug. Forgot Password and Send User Invite Error since this week


One end-users clicked the 'forgot password' link and received a 'forgot password e-mail', however, when clicking on the link they get an error message;

'invalid token'

To another end-user, I have send a Retool invite. The user received the invite, however when clicking the link, they get an error message;

'No invitation found with that signup token'

Schermafbeelding 2024-03-20 105454


Any updates? Unfortunately we still cannot add users or change passwords.
We get 'invalid token' message.


Hi @ellenhelena, happy to help! :slightly_smiling_face:

We were not able to reproduce this issue on our end, but let's check a couple of things.

Could you try resetting the password of an account you have access to? It's possible that the reset password link had expired for your user but is showing the wrong error ('invalid token').

For the issue with the invites, if you go to the "User Group" you invited the users to, do you see their emails as pending?

Hi Paulo,
Thanks for your reply, sorry for the late response. I have been in contact via the support@retool mail with one of your colleagues. Unfortunately it's not solved.

  • Tried a new reset password link, also for other accounts, but encountered the same error.
  • Noticed that invited users had a status of 'pending'.
  • Sent invitations from Incognito Chrome.
  • Opened invitations from Incognito Chrome.
  • Revoked the invite.
  • Resent the invite.
  • Invited users with private email addresses instead of work account.
  • Invite users with another admin account.

The issue now is, that we cannot add any new end-users to our Retool Cloud instance.

Hi @ellenhelena, check you DMs. :slightly_smiling_face:

1 Like