Change domain name: failed to add custom domain

Current plan level: Business

Question / Description:
I'm trying to change the domain name via Settings -> Branding -> Domain Name but it fails with an error: "You have reached the maximum number of custom domains for your organization."

Currently, there is no domain name active, but still i can access my account with the old custom domain name (


1 Like

Update 1: Now i get a 404 Not Found from nginx
Can not login anymore.

@joeBumbaca we're about to do the same this week (moving from / to and we would like to reduce downtime for our clients as much as possible. Is this a matter of retool backend being updated? Is there a way of syncing with the team in advance to ensure a smooth passage?


1 Like

Eventually it worked somehow, but i took about 2 hours to work as expected. Needed to change DNS settings of domains etc. Hope that helps

Follow along with the steps in our Docs on how to Configure a custom domain for Retool Cloud. This shouldn't take too long. DNS changes can take up to 24 hours to propagate in some cases. Wait until you can validate that your DNS is configured and propagated before moving forward and it should go smoothly!

Thanks @AbbeyHernandez.

We made the domain change, and is working great for all our users.

However, funnily enough it is not working well for me.

When I go to the new domain, I don't get the log in via Google option and when I try to log in with email and password I get an error.


I'm still able to log in via though.

That's really strange! Have you tried accessing the login from an incognito browser?

I just tried that, still the same.

You'll need to configure a Google OAuth client and integrate it with your Retool instance.

Thanks for sharing this Abbey.

Unfortunately we have built an external and client facing platform, so Google OAuth client is not an option. But is helpful to know what is the source of the problem.

Of course, thank you!