Retool custom domain: Cannot see Sign in with google

Hi, we have set up a custom domain for our Retool dashboards. However it seems like the session isn’t maintained across custom and non-custom domain websites. Check out the loom preview. We have hard-coded links to our custom domain retool apps. Without seeing the Sign in with Google button, we cannot use those links. Please help. Thank you.

1 Like

I am experiencing the same issue as well. When navigating to the login screen for our custom domain, there is no longer the option to sign in with google.

1 Like


+1 It's unbelievable that there's still no feedback from you Retool! It's a critical bug, our users can no longer connect!

1 Like

Also seeing this problem... any solution yet?

Hey @Rohit_Joshi @kexline4710 @bobthebear @Michael_Mondou @rstrauss Retool is unable to configure our Google OAuth client to allow requests from custom domains. Therefore the Google SSO functionality that Retool provides out of the box on standard, cloud domains (i.e. is not supported on custom domains.

To have Google SSO on custom domains you'll need to configure a Google OAuth client and integrate it with your Retool instance per Retool's Sign in with Google docs.

Thanks. That worked for me.