301 Redirect Trailing Slash in Public Retool URL


Ive recently encountered an issue that didnt seem to happen before.

I have a subdomain setup on my website to redirect my employees to my public retool app page, and its worked perfectly for 6 months, but as of about a week or so ago the page just comes up blank.

I did some investigating and found that the issue is the trailing / that gets automatically added to the end of the public retool url during a 301 redirect.
For Example it goes from: (Fake Urls BTW)

Adding the trailing slash during any http redirect is very common, and is an absolute pain in the ass to try to find a way to remove it somehow during the process. Cause even browsers sometimes just add it anyways.

When the trailing slash is added at the end of the UUID, the page loads blank, and the console shows an error "Invalid UUID"

Could you look into this and see if you can go back to handling trailing slashes at the end of public retool URL's again? Im not sure what caused this to break cause it worked fine for 6 months till now.

Thanks so much!

Hi Miles!

I'm able to reproduce the issue on my end and have opened up a bug report for this. Do you have an idea of when this first started showing up for your organization?

Thank you Alex!
I dont know exactly the date the issue started, but estimating about 2 to 2.5 weeks ago.

Hey @milesrae4! This issue in trailing slashed on public urls should be resolved now, can you verify?

Hi Alex, I have confirmed it works now. Thank you so much for the quick response and resolution! :slight_smile:

1 Like