App's Public link requiring users to sign in to view the Application

My team and I have a public app that has been working correctly for weeks, but a user just shared that they can not access the app because they must sign in or sign up.
I just tried accessing the link in incognito to reproduce the error, and I was asked to log in after the app loaded and then blinked out.

Hey! I'm one of the engineers who works on public apps. Looking at the network requests for your public app it seems like there's a file that was uploaded to retool and is being called. There's a known bug today that causes this to trigger a logout on both public apps and with retool embed. We're landing a fix shortly, but in the mean time if you link directly to that asset it should resolve the issue.


I've had a similar problem and assumed was a problem with the public links on the modules on the page. Fixed all those and removed any links to uploaded assets (basically images) and still not working - the link requires a Retool log in to view. Any updates @lukew ?

1 Like

I also removed the links and uploaded assets; the public link is still redirecting to a Retool login screen.

@lukew Good afternoon Luke,

I just wanted to check if there were any updates or maybe a fix we can do on our end in the mean time.

@RobWhite I just played around with some apps, and I got the public link to work by removing the images altogether from the published version. It is worth giving it a try.

1 Like

This issue still seems to exist.

Are there any updates on when it will be fixed?


I have the same issues. It seems the problem occurs when trying to download images from retool_storage.

Hi all,

We don't support Retool storage in components in public apps, but our team is currently working on this!

You should be able to create and use Retool storage queries in public apps, so you can work around the storage bug by querying storage objects on components directly.

This doesn't work yet:

This does:

1 Like

This issue can also happen if you use the comments component in a public app :disappointed:

Hey @lukew, I’ve encountered a hiccup with public app access. I enabled a public link for a Retool app yesterday, but end users are being redirected to the Retool auth page rather than staying on the app page. Is this a configuration issue on my end, or is it a known Retool problem? If it’s the latter, do you have any ETA on a fix, or is there a workaround I could use in the meantime? Appreciate your help!

Hi @Andres_Uribe,

Thanks for reaching out! I think this might be related to an incident we're investigating internally. The incident was just resolved though; are you still seeing this issue?

Hi @Tess! Just wanted to let you know that the issue has been resolved. Thank you for your quick response!

1 Like

So glad to hear!

yes still facing the same issue can you help me ?

Also got the problem here

I do see the page, then the redirect, not like an unpublished page :confused:

Hmm, thanks for the link! It looks like our engineers are looking into it! I will keep you posted as I hear updates.

Hi, I'm experiencing this issue as well — public link within an iframe, no storage components in the app, and yet the app is blocked by a sign in screen. Any updates?

Hi @mavenoid

Thanks for reaching out! Was it working previously?

Do you have a comments component in your app?

Are you able to share a link to the public app?