Who do some apps have a set Canvas to Desktop or Mobile option icons and some do not?

Some of my apps have this at the top:


Some do not. I would like to turn it off but I can't seem to find a setting for it.

Hey @bradlymathews!

That icon will typically display if any of your components are set to show on the mobile view:

You can try clicking over to the mobile view and then delete any components visible there or set them to only show on desktop. As long as there are no components to display the option shouldn't appear. Components should also default to only display on desktop when you create them for that view.

Can you let me know if that works? Curious to know if there might be something else going on.

Must be something else. The mobile view is empty. I looked at every component to double check none have the Show on mobile enabled.

I did try disabling mobile from the App settings, but the icons are still there just the mobile one is now disabled.

Odd :thinking: do you have either the sidebar or the header enabled for the mobile view? Also, what's the width of the screen you're viewing the app on?

Headers for desktop and mobile are always enabled by default, at least for apps of this age (created on Nov 11, 2022).

I deleted the header in the mobile view and the desktop/mobile icons disappeared after returning to desktop mode.

So the header is assumed to be a component to the logic the decides whether to to display the icons. Something to pass on to the engineers to fix I guess.

Thanks for figuring out where to look!

EDIT: Wait, my desktop header disappeared as well !!!! it appears the header is for both Desktop and Mobile. Deleting it certainly does remove the icons, but also your entire desktop header.

Instead of deleting it can you try setting it to also not show on mobile? When you select the header itself, you should be able to see an inspect panel similar to what you would get with other components:

Ok that seems to have desired effect.

I should note that some of my apps do not have the icons and do have the header enabled for mobile.

If I uncheck and re-check the Show on mobile in those apps, then it behaves in this new way.

Oh odd, I'll see if I can repro! Thanks for surfacing the behavior :slightly_smiling_face: