Runtime error: exited workflow with code 139

While debugging something I got this error message in the workflow logs:

Runtime error: exited workflow with code 139

Googling it I saw:

"When a container exits with status code 139, it's because it received a SIGSEGV signal. The operating system terminated the container's process to guard against a memory integrity violation. It's important to investigate what's causing the segmentation errors if your containers are terminating with code 139."

As I had been editing a loop over an array I figured I must have screwed up and I wrote some guard code around the subscript on the last iteration and proceeded to try again w/o thinking much of it. And my next test worked so I figured that was it.

Later on I was looking at the logs for a different reason and I saw it again. This time in a different location. However the code is running to completion too and otherwise working.

I have no idea now if this message has been showing up for some time and I've just ignored it. The run history is showing a red X for everything....but nothing unusual about that. And you click into it and see that the webhookreturn is green. Again nothing too unusual about these conflicting signals....

Searching in I don't find anything reporting on this error.

I see the IDE "expand" button to open up editing Javascript in a bigger window has disappeared. So I suppose a new build got pushed...

I'm having the same issue

Our team is investigating these errors! If anyone can share the specific day/time that the exited workflow with code 139 error came in, that would be helpful

Here's one! Hope that helps!

1 Like

Thank you! Shared this with the team that is working on this issue :pray:

I'm seeing this error as well. Has there been any update on how to avoid this error?

I am attempting to read a ~3 MB csv file before doing an update operation to the a retool db.
The workflow works with no issues a smaller test file.
Ultimately I need to be able to run with much larger files (> 30 MB)

Please advise. Thanks. Mike

Hi @Mike_Simmons thanks for checking in! It looks like our team is still investigating this error :disappointed:, but I'll add an internal update noting that we have another example of it.

I'll reach back out here with any updates that I get internally

Hi @Tess I believe I'm having a similar issue here Workflow - Runtime error: exited workflow with code 139, any workarounds or updates on this one?

Hi @Kovon Thanks for checking in! Unfortunately, I don't have any news on a fix yet :disappointed:

Since you mentioned it is working for smaller sets of data, could you loop through the data in smaller batches?

I programmed an error into my Javascript Code Block in a Workflow. That logic error of mine caused an infinite loop, and this code 139 error message. When I fixed my logic and the infinite loop, everything went back to functioning correctly


1 Like

Thanks for reporting this! Will update if I hear anything further internally, but I'm glad you were able to move forward

Any Update on this one? I start to get the same error just from today, and I didn't change any in workflow.