Non-Editable Cell in Table Component Changes Cursor to I-Beam

I noticed this starting a few weeks ago. When mousing over a non-editable cell in a Table component, the cursor changes to an I-beam (indicating editability). This is new default behavior and confusing to users. Is there a way to change this? Is it by design?

I have noticed this as well. It should be fixed. And this only happens on certain column types.

Hey @sfbrophy! Echoing what @ScottR said :sweat_smile: I just created a bug report for this, and will keep you updated on a fix. This definitely shouldn't be happening, so I appreciate you writing in about it!

Hi again @sfbrophy! This should be fixed now—how are things looking on your end?

New to retool and loving it so far. I am having a similar issue where all of my non-editable cells are showing the I-beam on hover, can I change this? On top of that, I would like to change the cursor for specific cells to a "Pointer. These are cells ("Proposal PDF" column in my screenshot) that use the Status Indicator to change cell content and also change the function of the cell when clicked. Is that possible?

Hi @kporter! Glad to hear your intro to Retool is going well! :tada:

I'll report the I-beam on hover behavior to our team & post back here when I get updates.

In the meantime, it looks like you can modify our default cursor settings with custom css. Custom css can be a bit of a hacky workaround, but wanted to share just in case!

Thanks for the response @Tess. One thing I noticed on the I-beam is it only happens on the front end of the app, if I am editing the app it does not show the I-beam cursor.

I was able to get the other cursor working as needed by using CSS data attribute selectors and putting the data-column-id in brackets to apply the CSS to the entire column. I put an example below for anyone who is looking to do something similar:

[data-column-id="39c49"] {
cursor: pointer;

1 Like