Text Field Cursor Jump

I have an odd problem that appears to be isolated to one app, but I'm not sure how to troubleshoot it. When typing into a Text Input or a Text Area, the cursor jumps to the end of the string after each character is typed (or deleted). This happens in one app, and a module that is loaded within the app. Other apps of mine seem to be working as expected. Any suggestions on where to look, or how to narrow down what's causing it?


I've tried adding a new Text Area component, and it behaves the same. I've tried browser cache clear, and a couple different browsers. No doubt it's something in my app, but I'm drawing a blank on what/where to check. I believe this just started happening today, without any new app release on my end, but can't 100% confirm that.

I duplicated the app and 1 by 1 removed all the components and queries, leaving just a plain Text Area, and it was still doing the cursor jump. I was stumped, but then realized I had bumped the Body Text size to 14px. Resetting to the defaults fixed the cursor jump?! I know there's concern with using Custom CSS for styling, but this is one of the pre-canned options under App theme.


I have users that have a hard time with the 12px font... Help!

Hi @Matt_N Thank you for reaching out! I believe our team fixed this bug :crossed_fingers: Can you confirm if you're still seeing the issue?

I tried a couple quick tests this morning, and it does look like it's working properly now. Thank You!

@Tess you indicated you thought the bug that @Matt_N reported was fixed, but it is not.

We are on current Retool cloud version 3.39 (cache cleared), using latest Chrome... and can replicate jumping cursor issue at will. Behavior occurs when editing an existing note - as soon as I type a few characters, cursor jumps to the very end of the note.

Please see your internal support ticket 75994204217675 for link to video and also JSON export.

In addition to jumping cursor, we are having to type extremely slowly in the textarea input to avoid characters getting skipped. Frankly, we are now resorting to typing notes into Notepad and then pasting into Retool TextArea field the speed problem is so bad. I would appreciate your looking into both issues.

We have 30 users on a production app and all are expressing super frustration with both typing speed and jumping cursor. Please advise, thank you!

Thank you for flagging! We will re-investigate this issue

Hi @Tess do you have a status update? Please PM me with details, thank you!

This is affecting our team too on retool cloud.

Do you have an update on when the jumping cursor issue will be fixed?

I don't have an eta yet :disappointed: I'll post here when I get any updates