Workflow Using 100CPU - Completely stuck


I was working on a Workflow, everything was fine until a few minutes ago.

It's now consuming 100% of the CPU on a Macbook Pro M3 Max 16-40, 128GB Ram. I can't work on the workflow anymore.

I tried to:

  • Restart my browser.
  • Restart the computer.
  • Use a different one (firefox, chrome, arc) the issue is similar.

:point_right: Anyone faced a similar issue?

Safari fixed the issue, but the workflow is still consuming 100% CPU on the other browsers.

Hi @som!

Is this happening on cloud or a self-hosted deployment? If it is on cloud, would you give me permission to access your workflow through a support account to help debug the issue?

On Cloud, sure you can but the workflow is messy, also I've moved forward with safari (so the state since the bug has changed)

Could you please try again on Chrome? We just rolled out some performance improvements that should make working with large workflows faster.

If you're still seeing this issue, please DM or email me (andrei at your retool URL, and I can help debug it.

@andrei I've just tried again, the issue seems to be fixed (CPU back to <2% on Arc). However, keep in mind that the workflow is not in the same state that it was when the bug occurred.

I will contact you by email/here in case of sudden new CPU consumption.

Thanks for your efficiency.