Workflow python boto3

Hello folks,
based on the docs Self-hosted Retool release notes | Retool Docs there is should be boto3 support.
however, in workflow I've got:

Current version 3.8.15

Appreciate any help.

also there is no boto listed Execute Python with the Code block | Retool Docs

Updated retool to 3.10.7 and temporalio to 1.22.0.

The same error.

boto3 lib version is 1.26.151.

retool 3.12.4 - no luck.

Anyone? Guys from retool? Should we raise support issue for that?

3.16.1 still the same error.

Hey @Punka! Taking a look here.

Does this work if you use the import statement in the Configuration panel on the left?

Thanks Joe!
Nope, it doesn't work. Forgot to mention it here. I've tried :frowning:

Any docs or instructions on how to enable python in retool self hosted?

I've also been playing around with the one offs report here to get the latest versions.

Nope and I guess it'll be delivered to on-prem not so fast.

So workflow is the best choice, and then you can use workflow in your app. Hope that helps.

Also some external functions or smth like that were introduced, but still only lame aka JS is supported.

Hey @Punka, looks like this is an issue with the library not being available in the older code-executor image. Can you try using tryretool/code-executor-one-offs:3.14.13-d3f3a08 instead and let us know if that allows you to use the boto3 library?

1 Like

It works! I will sort it out creds etc tomorrow but import works like a charm!

Thank you Joe and I am glad we have managed it :slight_smile:

1 Like

@joeBumbaca sorry for bumping the resolved topic but don't wanna create a new one for the related question - is there a way to use AWS IAM Role when deployed on EKS?

I sh'ed into the pod and looks like there is python's venv created w/o any env variable.