Self Hosted Plan - Unable to see python blocks

I'm using self hosted retool. Currently on the free plan. I've deployed the service without temporal. I do have code-executor setup and configured in the backend. When I create a codeblock there is no option to switch to python.

Can you help me with this?

I've setup temporal as well. But the service seems to think temporal is not setup.
I don't see any logs that can give me a hint on what exactly is happening.
I've all the 4 env variables configured

Am I missing something?

The workflow configuration API is returning everything as false even though I have set these up.


I tried setting up locally and it works fine. But on ECS (where I upgraded the existing version it's not). Also, I noticed that there is no log that says

Creating new temporal client

in my ecs setup. any idea why it's not trying to connect to temporal even though the front end is configured?

I've solved the code-executor issue. retool backend was not able to connect to the code-executor.

I've ensured that it's able to connect to temporal. but still the workflows show that it's not deployed.

Lack of error logs is not helping.

I've solved the temporal issue as well. It had connection issues and also was expecting a namespace called workflows.

But now my code-executor fails with the following error:
[E][2024-05-04T16:13:27+0000][24] standaloneMode():275 Couldn't launch the child process

Also, After sometime it crashes because of something related to datadog.
/retool/code_executor/node_modules/dd-trace/packages/dd-trace/src/plugins/tracing.js:97 retool-code-executor
May 04, 2024 at 21:40 (UTC+5:30) if (!span._spanContext._tags.error) { retool-code-executor
May 04, 2024 at 21:40 (UTC+5:30) ^ retool-code-executor
May 04, 2024 at 21:40 (UTC+5:30) TypeError: Cannot read properties of undefined (reading '_spanContext') retool-code-executor
May 04, 2024 at 21:40 (UTC+5:30) at ChildProcessPlugin.addError (/retool/code_executor/node_modules/dd-trace/packages/dd-trace/src/plugins/tracing.js:97:15)

can you help here please?

Although I see success sometime in code-executor. the worflow itself remains in inprogress
--- Successfully finished running the workflow ---

I’m seeing this same issue. The code-executor container starts, throws this same child process error a couple times, and stays running but retool doesn’t know it exists (ie. No python code blocks). Hopefully someone can help us shed some light on what this error indicates.