More key rotation errors

I have asked alot of about key rotation

Unfortunately I did not test everything and have these issues now in production

Workflow errors

I can run a workflow by hand, meaning block by block or all blocks before, but running it with run function, and hereby triggers, produces the screenshotted error. This error manifests in the UI as just run and all blocks get a grey icon.

Decryption error when connecting to slack

Im trying to authorize a new slack, and I thought it worked, but now im getting this strange error. Any help to get in this case?

Screenshot 2024-02-05 at 12.16.35

So, the issue with workflows have been solved. The issue is that the worker pod never got the upgraded key through deployment. As the worker pod was not affected by resource change i decided to upgrade with. In staging we upgraded versions, which affects all, but the versions of the prod servere was already upgraded, and I did not want to downgrade, and had not a new version to go to.

So its very related to selfhosting and how the deployment pipeline works.

The part about decrypting slack is working fine in prod and I dont want to spend time to solve it, as it is not affecting us