Table loading spinner at wrong position in tabbed container

Hi there

In my table (upgraded to newest version) I have the option "show spinner when data is loading" on. And it also shows a spinning wheel but it is way down and on smaller screens only visible when you scroll down.

Also: all components of the tab are greyed out (and unresponsive) while either of the tables in the tabbed container is still loading.

Is there some way to fix it?
We're using the cloud version of retool and the table is part of a tabbed container (also updated to newest version).

Attached is a screen recording to show what's going on.

Screen Recording 2022-04-29 at 14.42.03

Hi there @hansaplast :wave:

Oh boy :thinking: yea that's a bid peculiar and we definitely don't want that happening and delaying your work-flow. It looks like the the entire lower portion of your app is dependent on the selected row of the first upper table. Some of the information populates quicker than others it looks like. Are these queries being triggered from one query itself? Maybe the scroll is waiting for the main query to finish; I'm not entirely sure.

May you share what sort of behavior you're seeing when you disable the scroll option? I'm curious as to why the greyed out thing is happening.



Hi Pawan

Thanks for your nice answer. This forum is great, and it's because you guys commit to listen and giving good answers!

Yes indeed the lower part is dependent on the selection of the upper table.
More in detail: the upper table has an action event set on row selection which triggers a javascript query which triggers all queries which are relevant to the current tab (there are so many queries in total on this app and I don't want to trigger them all, only the ones which are relevant for the current tab).

Oh, I wanted to see what the "scrolling option" is and just stumbled over the "Hoist loading state" option which says "show loading state when inner components are loading" and that was it! :slight_smile: I disabled it and now the tabbed container is not greyed out and there are individual loading animations for the different components. I'm super happy :slight_smile:

any way to disable those loading animation at all?

hey @agaitan026 it looks like this was discussed over here! Hide spinner when data is loading - #4 by PeteTheHeat

1 Like

yes done it works thank you

1 Like