Stage environment is disabled

  • Goal: I am trying to use a stage environment.

  • Steps: I enabled the stage environment in the resource. The App I am using is connecting to that resource. Yet stage is still disabled with the following message.

The staging environment is disabled because the following resources don't have a configuration: . You can configure them on the Resources page.

Note that it is calling the resource name an empty string.

Hi @Augustin_Kim, welcome to the forum! :wave:
Following up from office hours, I tried reproducing this issue. This is what I found:

When all the "Resource queries" from an App are using a resource where the staging environment has been enabled:

I am able to change environments:

Initially I though the issue may be coming from having a query in the app that is empty or erroring out, but I am able to change environments whether the queries are working, failing, or empty:

I also tried giving this "User Group" access to a resource that doesn't have the staging environment enabled:

And as long as the query is not used within the App, I'm still able to change environments, even if there is a shared query in the "Query Library" that is using the resource with no staging env enabled.

We did look at all your queries during OH and I can confirm all of them had the correct resource (with staging environment enabled).

About the empty string on the error, it is a current bug we have. It should be showing the right resource that is being used within the app in which we have not enabled staging yet. Our devs are working on fixing it. :lady_beetle::no_good_man:

For example, I run into the same issue when I add the query from the "Query Library" that is using the resource with no staging env.

I'm going to do some more testing and get back to you.

Could you try making a new app with only one query that uses this resource? Try changing environments then. If that works, we can either build up on the new app, or remove queries from the original app, one by one, until we are able to change environments.

Let us know how it goes! :slightly_smiling_face:

Hello Paulo,
Thanks for looking into this and getting back to me. I created a new app and added multiple queries that were linked to the same "local" resource. I was still able to toggle between staging and production.
If we needed to remove the queries one by one, that would be quite burdensome. I have many apps and many queries tied to the apps. I'd prefer if we did not do that.


I'm glad that you were able to toggle between staging and production environments on the new app! We could export the original app as JSON and create a new App from it. This way we won't need to delete each query, it may just work right off the bat.

This did not work. Even if I copy and delete everything in the whole app and then try to connect the query, I still cannot toggle to stage. But if I create a new app and connect to the query, I can.

Hi Paulo,
We really need this fixed ASAP as we are releasing soon. Do you have any updates on this?


Hi Austin, we have not been able to repro this bug but I would love to give it a shot with your JSON export. Could you attach it here so we can take a look at it? It should only export app configuration so your data will stay private.

Internally, I found there is work being done to:

"Fix environment switcher edge cases; you should still be able to switch to environments in the editor even if you don't have write access to all resources; should allow use access as well"

If I remember correctly, you had enabled edit (write) access to the resource. However, this work on the environment switcher could fix this bug when the updates are released, but there is no current release date and your team is planning on releasing soon.

We are also happy to take another look at it during office hours tomorrow at 11am PST.

Hello Paulo,
Here's my json.
I'll also stop by office hours.


School.json (396 KB)

Awesome! Looking forward to seeing you there. :slightly_smiling_face:

Before changing the resource on one of the queries, I am unable to change environments:

However, the moment that I change the resource to one where staging has been enabled, I am able to change environments:

This is a great sign that we don't need to build the app from scratch again. It may be something we are missing with that specific resource you are using.

I believe that is because you are not changing the resource to one of our existing resources that has staging enabled. The bug seems to be a problem with if I had a resource that did not have staging and enabled it later and then tried to connect, it won't enable the staging toggle.


Resource with no staging environment:

Creating a brand new app from JSON:

Unable to change environments:

Enabled staging environment:

Now able to change environments:

Perhaps we forgot to click "Save changes" after adding the staging env?

Hey @Augustin_Kim, I sent a DM for you to attach the second JSON file, with the blank UI, that still had the environment switch issue we saw during OH. I'm not sure about where the first email was sent to, since we were not able to find it in our inboxes. Otherwise, feel free to upload it here if you would like to.

Hello Paulo,
It says new users are not allowed to upload attachments. If you can figure that out for me I will go ahead and upload the json files and the images with the discussion we had today.

Does the same apply for the DM?

Can't figure out how to DM.

Click on your profile avatar on the top right of the page, then the messages icon. You should be able to find the message I sent you there. :slightly_smiling_face:

Ya says same thing.

Interesting. I found a faster solution than deleting all the queries and re-adding them. You can just select the "Version" of the query from "Latest Version" to the latest date there is, save, and then the reference is updated. You can toggle it back to "Latest Version" if you like. So it looks like "Latest Version" did not update to the actual latest when I had a new version of the query. So I believe that when a new version of a query in a library is created, it should trigger an update on all apps that are tied to that version.

Edit: be advised... that can potentially put your app in a permanently broken state if you have a trigger with a redirect and that was dependent on a query. Good thing I made backup copies of all my apps or I would have lost two of my apps.