App changes not being made

Hi hi,

I recently joined a team to help them on building an app, but when I started making changes and saved a new Resource query this won't save but instead it kept loading. I tried refreshing the page but that erased all the changes I've made. I tried saving manually but no indicator appeared.

I thought maybe some other colleague was inside the app and that created some conflict so I duplicated this app and started working on the new one but there happened the same thing.

It's not a general issue because when I edit another app that I've been working on the changes are saved normally, and if I create a new one from scratch it works fine too.

What could be the cause?

I searched for similar questions and found this one and also this one, but I don't think they're related to my problem.

Thank you in advance.

1 Like

Can you explain this part in a little more detail? You created a new query and when you saved the query what "kept loading"?

In general, like you've described, changes that are made to an app will be automatically saved. This will not be the case if the app has a release history, though. In that case you would need to publish a draft of the app.

Either way, undeployed changes to a versioned app should still be present when you make changes as an editor and revisit the app, so I'm wondering about the "kept loading" part for now.

1 Like

The part about "kept loading" is that the query won't save. In the image below see that the "Save and Run" button is spinning, that won't change, it has been like that for 20 minutes now.

And I know the thing about releases, I tried making one and I could do this, but new changes won't apply to this new release.

The thing about changes not being made is that if you normally make a change and reload the page you will be able to see it (I'm referring inside Retool editor, not in an embedded page or something else), but I don't see it. If I add a text, there will be gone, if I create a query, it won't exist. Changes aren't being saved :frowning:

What is seems like is that your query (Databricks resource?) has caused some sort of app related breakdown which is preventing any other things from being changed.

Is query13 still in the app when you get back into the editor and always doing the same loading behavior? If so, you might be able to use the history offset of the app to go back to before you added query13:

Pinging the @retool_team for extra visibility.

1 Like

I don't think it's the query, or at least not this new one :thinking: because the changes won't be made either I create this new query or not. To answer about if this query is present when reloaded, the answer is no, because it's a new change and new changes aren't being saved.

In summary: to test if the changes are being saved in the app, I made three things:

  1. Create a text in any place of the app.
  2. Create a resource query.
  3. Modify an existing component.

If I make one, two, or the three of them, when I reload nothing is saved.

And because of this, I think the history solution won't work, because when I reload and search for the last changes there aren't any of the things I've recently made.

Wouldn't hurt to try though. If your app load state is always at the point where you are unable to make any changes, then the last change made that could have caused this issue in the app might be in the recent history.

If it isn't, or doesn't work, oh well -- at least you tried. Hopefully the back and forth will get Retool eyes on the specific app/issue quicker. If it does work -- huzzah! Hopefully whatever borked the app doesn't happen again :smiley:

Either way, good luck!

1 Like

@pyrrho Thanks for the assist!

@deipzza A few questions here:

Are you using Retool cloud or self hosted (if self hosted which version)?
Can you share the browser dev tools network tab when you add a component to the canvas? There should be a save query sent, would like to see if it fails / what errors are in the console / network tab.

1 Like

I'm not really sure about this one, how can I know?

Well, I think this told me the problem. The save request throwed a 403 Forbidden saying:
{ "statusCode": 403, "error": "Forbidden", "message": "You don't have access to save this page. It has resources you don't have access to.", "data": null }

I think I should talk with the owners of the app about this.

1 Like