Schema browser does not show tables

I am using Postgres to bring in my data. My issue is that the data does not show up in the schema browser. Is there something that I need to do for the tables to be visible?

I did confirm that the connection is successful. I also tried to run a query but was unsuccessful in ReTool. I get an error stating that the table does not exist.

Hey @djbeto2209! Usually, if your schema is not showing, the resource is not properly connected.

I'd be interested to see how you have your resource setup. Are you using an Retool oncloud or onpem?

I am using ReTool OnCloud I think. My resource connection shows successful when I test it from the Resources tab.

Hey djbeto2209, the 'Test Connection' on the resource page can return false positives in some situations :confused: If your schema isn't showing and all queries are returning as unsuccessful, then your resource is not connected.

Here are our docs on troubleshooting resource connections. One common issue cause of resources failing to connect is if you haven't whitelisted Retool's IP address in Postgres.

If you can share your resource setup we'd be happy to help troubleshoot the connection!

I am having a similar situation. I just created a table in an Azure SQL server that is otherwise successfully connected to my Retool app. In fact I can connect to this table by writing a query "select * from [foo]" and that actually works. However if I try to use GUI mode in Retool (I want to do an upsert operation) a menu is presented to select the table and this (new) table does not appear in the menu and it won't let me type it in like I can with a non GUI mode query.

There is nothing strange about this table other than it being "new" (nearly 24 hours old at this point).

Well I just found the nicely hidden "Refresh schema" button and that fixed it. :roll_eyes:

Where did you find that button @Roland_Alden?

It's better hidden than the butter in the fridge, and I can't find that on a good day.

Well in changes to the IDE UI it actually moved since I made that post. It's now about as far away as it can be :joy:

Thanks, found it.