New Retool Database table not appearing in Resource Query list

I've just created a new table via the Retool Database, but it't not showing up in the 'tables' drop down menu in GUI mode. I can already query it via SQL mode though.

Is there a delay in these turning up? I ran into the same issue with a new managed_db table and it appeared later.

How long is the delay? Anyway to speed this up?

Hey @joostschuur!

Have you tried using the refresh schema button?

1 Like

Ahh, that does make the new table available right away. In my head I probably associated that area with a specific table's schema and not the complete list of tables. Good solution for now :slight_smile:

Weird. Were is that snip taken from? Its so small I can't seem to relate it to what I am seeing on my screen. I am also not able to get a new table in the database to populate the list in a query drop down.

All I can find is this


This refresh button does not fix my particular issue.

Hey @shawncrocker sorry about that!

It should be in the app editor itself:

Thanks. I didn't notice the fly out the exposed the resource schema.

Hi Kabirdas, this feature is missing in workflows. I managed to workaround by creating a query in an empty app and then go back to workflow but there should be a button to refresh the schema in workflows in my opinion.


Good callout @Lukas! It's something on the dev team's radar and I can report back here if it gets included :slightly_smiling_face:

Hey @Lukas!

Just want to make sure you're aware that Workflows now has a button for refreshing your schema:

Along with an indicator of the last time the schema was fetched :slightly_smiling_face: