Retool UI has become extremely buggy


As of today, editing apps in Retool has become very difficult to use. Certain UI elements don't seem to work properly -- for example, adding text to certain elements seems to have an extreme delay to the point where it is almost impossible to type. Scroll bars also do not seem to work properly.

Here are videos of these behaviours:

I have tried both Chrome and Firefox on MacOS and have been able to reproduce this. Another developer working on this project with me was also able to repro on a different machine (though I'm not sure which browser he was using).

At the same time, I have noticed that certain changes that I make to the app don't seem to save. If I make a change to a query or component config, for example, then refresh, the changes don't stick. To be absolutely sure that no one else was overwriting my changes, I force signed out everyone else who was logged in and closed all other browser tabs, but this did not solve the problem.

Hey @jrobin1917! What version of Retool do you use? Do you use cloud or on-premise? (If on-prem, what version number?)

Hi Darya, I am using the cloud version.

Hey @jrobin1917 -- would love to hop on a call with you to try to debug what's happening here.

If you're available, here is a link to a Calendly with availability this week (and beyond): [removed the link].

I work PST hours, but if those hours don't work for you, let me know and I can open up spots that work better for you!

-- Darya

1 Like

We are having the same problem. If I type at normal speed the text input misses a bunch of characters.

Hey @DuncanRitchie -- you are welcome to sign up for a debug session as well! Link in my previous comment.

Hey @jrobin1917 @DuncanRitchie -- we were able to reproduce the text input issue from first video!

Do you happen to have this setting turned on for your table component? We think this is related:


It's in 'main table inspector' => Appearance => Advanced

Going to continue debugging this on our end. Thanks for bringing this to our attention!


If you do happen to have this setting turned on, a temporary fix would be to turn this setting off, and that should fix the flickering. We are working on a fix though, and will let you know when it's out!

Recently encountered errors with a table I was trying to modify being very glitchy, turning this setting off did fix the issue for me.


@ezerjesse @jrobin1917 @DuncanRitchie -- We have pushed a potential fix to the flickering inspector issue. Can someone refresh their page, and then confirm/deny that if you turn Automatic column width back on, that the glitching is not there?

1 Like

Awesome! This solved the glitching issue I was having. Thank you.