URGENT: Table on production screen not displaying

We have a production app that displays table results. This screen was working about 1:30 PM Pacific time today but it no longer displays results.

I confirmed that the query is returning data and the page numbers are properly displaying but the table is empty.

Was there a new build from Retool this afternoon? Can you please look into this ASAP? I can provide the URL for that screen and any other details.

1 Like

Hi @howie! Thanks for reaching out.

There has not been a new build since earlier today (before 1:30 pst)

I am not getting similar reports of this, but I would love to take a closer look. If you're on cloud (not self hosting Retool), I'm happy to log into your app (with your permission). Just post the URL and confirmation that it's ok for me to take a look.

If you're not interested in that or are self-hosting, can you check to see if there are any console errors?

One option that might help in the meantime-- is to try using the ?_historyOffset=2 parameter at the end of your URL. This will allow you to "travel back in time" 2 steps. You can increase the number to go further back in time if you still don't see any table data. The idea here is to go back to the most recent working version so you don't have to redo as much work (going back 1000 steps would likely show data, but it could be many, many changes behind).

***WARNING!*** If you make any changes to the canvas when traveling back in time, that past version will become your present version and it messes with the history, so be careful not to touch anything! Once you find a version that isn't crashing and you'd like to make that your present version, then you can make an edit to the canvas (move a component, add a component, etc) to persist that view.

@Tess here's the URL:

Feel free to take a look. You can run search with today's date and you should see 7 pages of results but no data in the table

Hi @howie! It looks related to the table's right panel settings for sorting.

If you change the column field from sort to name (or any other column), does the table load?

We're seeing this too in the table component, when we load our app the table is empty. However we can see the data in the returned query and when we click the "Edit app" button, the table renders with the data.

Hey :wave: ! @Tess I'm having a similar issue––my queries all look good, and in the right sidebar it looks as though the table should be displaying data.

However the table isn't rendering. It randomly rendered in edit mode but I couldn't reproduce it.
I tried your tip, changing the sort (which I haven't messed with until I saw this post-–all was working fine before with the sort I chose) and some sorts seem to show the table data again but the one I want doesn't.

I had this issue today too, and just filed Bug: error when trying to sort table by Actions: _sortedDisplayedDataIndices: Cannot read properties of undefined (reading '1') before seeing this thread.

I found that trying to sort by the Action column would consistently reproduce the issue, and clicking another sortable column would resolve it.

1 Like

Oh wow, thanks @ianm –– I tried hovering my mouse over the red anchor on my table but I guess I didn't hover it over the right place. I see the same error as you do now. Thanks for the tip and for reporting the bug! Keen to hear what the RT team has to say

@tntermini @ianm @anders @howie @maximus4133 @Tess
I was experiencing the same issue...a table that had been working the same way for the last 6+ months all of the sudden was no longer working. There was the red error message, that when hovered over displayed: _sortedDisplayedDataIndices: Cannot read properties of undefined (reading '1'). And if you manually clicked on on of the column headers to sort, it would generally begin to start working.

Here's the fix that I found:

Go to the affected table's settings (right-hand side in editor pane). And check out the 'Default Sort' drop-down menu. Make sure that the title of your column that you intend to be selected, is actually selected >>> make sure it has the appropriate Capitalization, too!

In our case, our column that was the default sort column began with a capital letter, and the selection in the drop-down for 'Default Sort', was all lower case. This table, both on db side and also retool side, hasn't been touched in months...so I believe there is a bug that was introduced.

Hi Everyone! We're taking a look into this now and should have an update within the next few hours

Ok, thank you all for the reports here! We believe we've found the cause of this bug and implemented a fix, would you be able to verify that everything looks normal on your end now? If anyone is still seeing odd behavior please let me know and share a link to the app :pray:

Everything is working for me now! Thanks for the fix.

1 Like

@alex-w Working for me too! Thanks for the quick fix guys!