Retool doesn't use the latest version

  • Goal: using the latest version always

  • Steps: I've edited the app and it's not using the latest version

  • Details: we recently downgraded to a free account that doesn't have releases

Hi Ohad_Perry!
When you say that your edited app is not using the latest version. Are you referring to the releases feature that gates any changes? Also are you on cloud or self hosted? What Retool version are you on?

hi.
I'm editing the app and when users go to the view app at url
https://bllink.retool.com/apps/e1e5f5f2-2c48-11ed-a21c-339ae6d8b18f/features/change%20any%20feature%20for%20anyone
They see they last version.
and not the most recent one

any updates? happens for other apps as well.
I'm updating the app and users don't see the updates.

No updates as of yet, can you tell me if you are getting any errors at all when the page first loads? Also how are you deployed and what version of Retool are you on?

  • Retool version 3.65.0


here is another example from another app

Hi Ohad_Perry,
We are looking into the matter internally. We will update you shortly! Thank you for your patience.

Okay Ohad_perry,
Looks like your release feature is still in effect but you are unable to access it due to your downgrade. We have given you a week of our upgraded plan so that you can access this feature again. Once you make it to your apps you will have to go to the latest release and "unpublish" the current release. By default Retool will use the latest version now and forfeit using releases all together. If you do not "unpublish" these releases in every app then the issue may persist.

1 Like

hi.
can you give us another week. I missed the "unpublish" solution and the issue still persists

Of course! This upgrade will expire on 07/08/2024.

still not in effect

@AbbeyHernandez @Diego_Chavez still don't see it. can you verify please

Hi @Ohad_Perry,

Sorry I was OOO. Try checking again. Your account should be on business.

Thanks @AbbeyHernandez !

I unpulished all the versions from all of our 100 apps
and that seems to have solved it

1 Like

Excellent! Happy to help :slight_smile: