I am unable to connect with azure database for mysql flexible server

I am unable to connectover ssl with azure db for mysql Overview - Azure Database for MySQL - Flexible Server | Microsoft Docs

Wondering if there is a workaround to using SSL for this data source


Hi @mksunitha, happy to help! Are you seeing any errors in your UI or console? Did you set this parameter mentioned in the docs you shared?

@Jay I tried without SSL and that works fine but was trying to figure out how to use it with SSL. Flexible server does support public cert https://dl.cacerts.digicert.com/DigiCertGlobalRootCA.crt.pem. Self signed checkbox in retool portal experience requires me to enter a key but flexible server just provides a Certificate authority instead. Hence wondering if there is a workaround to enforce SSL

Okay, what errors are you getting?

Thanks for sharing that! It looks like a past customer solved this in the past by adding newlines after "----" for both the beginning and ending comments for the Client Key/ Client Cert.