How do I remove the edit button for a user?

For a given user with 'read' permission for an app, when he is viewing that app, the 'Edit' button still exists on the top right.

A screenshot of the permission:


My understanding is that you must be on the paid version for that.

That's odd because when you go to billing it says 'End-user mode' in the free plan. Happy to pay for it, but I wanted some clarification.

You get the end user mode, but it still includes the edit button. It’s the “Unrestricted end-user mode” you are looking for.

Does that start at the $50 price point?


Unfortunately, it’s still not working. I’m going email Kent from the Retool team and post the solution here. Thanks for the help, Brett.

Hey Amos, you’re right - you get end-user mode, but in order to restrict a user’s access to only end-user mode, you’re looking at a Pro subscription.

Looks like you guys removed the end-user from the free plan documentation, but it's still on the 'Plus' plan:

Confirming that Plus plan will not give you end-user access before I upgrade.

I just upgraded to ‘Pro’ @ $50 per user and saw the change. Thanks!

Ah, I think we need to do a better job naming this stuff - with the plus plan you get end-user mode, but you cannot restrict to only end-user mode.

Glad to hear it worked!

Hey Kent - respectful feedback from a (relatively new) reTool fan. I think the 5x jump from Team to Business to get this functionality is too big a jump, especially for small businesses. I'm not talking about granular control, I'm simply talking about restricting access to the EDIT link. One option - it would be nice to be able to restrict editing to admins only and have "All users" not able to edit the link. I would pay 2x for this functionality alone but I think it will be a long time before we can justify that jump which is a shame.


(Just a quick note—I just also shared this feedback internally. Thank you for taking the time to share!)

I am having issues with this on Business Account, added a user and under permissions only have the following groups:

  • All Users
  • viewer

This user however can still edit, any advice?

Hi @r_britz! Happy to help with this.

Out of curiosity, is your "All Users" group customized?

And is this user in any other custom groups, by any chance?