How do I remove the country code with currency? When changing to CAD, it used to remove US before the $ but now it shows CA on all currency fields

Basically the subject; we started using Retool a month or so ago. I'm in Canada, and I noticed when I'd add a number input field for example and pick currency as the type, it would default to USD, and it would display the value as: US $50.00 for example.

I'd then have to change the currency on the field to CAD and it would immediately correct to just show $50.00.

As of a week or so ago, now it shows CA $50.00 in front of everything, even if I have it set to CAD. Even if I put it to USD, it then shows US $50.00. No matter what I try, it will NOT remove the country in front.

I've tried in multiple browsers and PCs and all my users are having this issue so not sure if something changed. Where do I set it in Retool to NOT display this as it's really ugly and unnecessary.

image

Hi @lmonroe,

Thank you for flagging this! I don't see a way to control this currently :disappointed: But I'll submit a feature request

@Tess Is something like roadmap or feature list your team can open to us? I want to know what will go on next step. thanks.

Not currently :disappointed: I know we've thought about exposing something like that here on the forums, but we don't currently share our roadmap other than through responses to individual requests. I am bringing this up again internally to see if it's something we'd consider doing in the near term

So just to make sure I understand fully as I'm in the process of building a portal to be used by several hundred users, there's NO way in Retool to NOT have it show the CA or US in front of a currency? Is there any workaround as this will be a dealbreaker for us. We are in Canada; all users are in Canada; we don't need it to show CA or US in front of anything, we would never work in any currency other than CAD so this is just wasting space. It additionally seems to be the users browser that dictates this, as Edge shows CA in front of the number, and Chrome does not. I need to be the one that controls it so that all users get the same experience, not their browser dictating what they see...

Hi @lmonroe,

Currently, it's determined via the browser :disappointed:, and we have a feature request on file to change the components to allow app editors to control how it looks instead of relying on the browser

On my side, on Chrome/in the US, if I set any currency to be CAD currency in Retool, I see the "CA":

If I override my Chrome browser settings to reflect Canada location, I see this:

Unfortunately, I don't have an eta for the feature request, but I'll post here if I do get any updates

May I ask where you are "overriding your chrome browser settings"? No matter what I do, I cannot make it change to not show CA in front of the currency. I've set my language to English (United States), I've tried just "English" and also "English (Canada)".

Online it says Language is how you set the region and therefore currency, so I'm not really sure where else to go.

Hi @lmonroe I was using this feature in Chrome to test: https://developer.chrome.com/docs/devtools/sensors/#geolocation

Oh okay, I'm physically located in Canada so that shouldn't be required. Very odd, no idea why I can't get it to not show CA before any currency. I wish I discovered this before spending so much time building my app since now this isn't going to work for us, but I'll keep an eye on here in case things ever change in the future. Thanks again.

Hello @lmonroe and @Tess.

Could I please provide a bump for this feature. When I set Currency Code to '' (empty string) it shows "US" as the prefix on the statistic component.

This does not seem like expected behaviour. Defaulting to US for an empty field does not feel appropriate when the alternative (remove the currency prefix from the component) seems like a trivial implementation.

Regards,

Stewart

Hi @stewart.anstey Thanks for reaching out! I've shared your feedback directly with the team that owns this setting. I don't have a timeline yet for this one, but I'll reach out here if I get any updates internally

HI,
This seems to still be an issue, any idea when it will be fixed?

When I select £ (GBP) it shows "£"
When I select € (EUR) it shows "€

But when I select $ (USD) it shows "US$". and it should show "$"

This is inconsistent behaviour and really not a good UX
You can see from the Screenshots - the label clearly states "$" but the actual control is showing "US$"
Screenshot 2024-01-30 at 17.49.07
Screenshot 2024-01-30 at 17.49.00