First key dropped after "Enter" when editing empty table cells in Firefox

As the title says, in this exact situation the first key pressed does not register and does not end up in the table cell.

For our use-case, this happens when using calipers or a bar-code scanner which automatically enter data, and then press "Enter".

This problem happens:

  1. On Linux and Windows versions of Firefox, but not Chrome.
  2. When navigating between cells using "Enter" or "Tab".
  3. Even if the data is entered with very long delays between inputs.

This problem does not happen if:

  1. The cell's current text is non-empty.
  2. Cells are selected with the mouse instead of keyboard.

Hi @prepka, thanks for posting! Could you share with us which version of Firefox you're working on that you see this event happening? Also, what's the column-type you're using that this is happening on?

I'm running Firefox 100.0.2

I was using the "Auto" column type before.
I just tried it again, and it happens with both the "Text" and "Number" column types.

@prepka, I've tried replicating this 'bug' on my end using Firefox on version 101.0 (Mac) and was unsuccessful. Could you try updating your Firefox version and see if the problem still persists?

Hey @Kenny,

I ran the same test on my Mac M1 Mini.

On Firefox (101.0) I can reproduce the problem.
On Chrome (102.0.5005.61) and Safari (14.1.2) I can't.

Did you make sure all the cells you were editing where empty? It doesn't happen if the cell already has text inside it.

@prepka I unfortunately don't own a barcode scanner for this case :upside_down_face:, but when inputting data into an empty table cell I'm able to successfully input numbers when pressing "Enter". Could you share a screenshot or screen recording what you're seeing?
Screen Recording 2022-06-13 at 12.07.36

I think you can't reproduce it because you're selecting the next cell with your mouse.

I couldn't figure out how to upload it into a comment. So it's hosted here.

Chrome is on the left, and Firefox on the right.

By the way, I do appreciate the effort you're putting into this issue.
For our use-case, asking people to use Chrome is an acceptable workaround.