Cannot pull the latest version of Retool app

  • Goal: Was using Docker image to build local host Retool app.
  • Steps: 1. Curl the repository from github and unzipped it.
  1. Relocated into the folder, updated customized user configurations.
  2. Updated Dockerfile's Retool version
  3. Docker build and found the app version is 3.8
  4. Manipulated pulled the latest version and build again
  5. Double check the app version and it was still 3.8
  • Details: No components were used, just self hosted Retool docker image. Running on Ubuntu 22.04.3. The expected version to be used was 3.33.26

  • Screenshots:

Hello @nanwu!

It sounds like you followed all the right steps correctly, that is very odd that you are on version 3.8.10 :sweat_smile:

Could you share with me a screenshot of your CodeExecutor.Docerkfile and your Dockerfile file so I can take a look at the version on those?

They should both match and should be changed to 3.33.26 if they are showing up as 3.8 it shouldn't be hard to change and re-run.

Hi Jack, thank you for reaching out. Here are the screenshots of CodeExcutor.Dockerfile and Dockerfile.

As you said, They should both match and should be changed to 3.33.26. So I have also tried to keep the version in Dockerfile as 3.33.26, and CodeExcutor.Dockerfile as 3.33.8(Which is the latest one can be found on 3.33). But I still got the same result in Retool app, which is 3.8.10.


Hi Jack,

Thank you for taking your time. After I tried to remove my local docker image of 3.8, and I re-pulled the docker image, it finally got 3.33.26. But I think it is better to allow the docker image to get upgraded without removing local docker images. Anyway, thank you so much!

1 Like