Starting retool gives error: service 'db-connector' failed to build : Build failed

~/retool-onpremise-master$ sudo docker-compose up
Building db-connector
[+] Building 1.7s (3/3) FINISHED docker:default
=> [internal] load build definition from Dockerfile 0.0s
=> => transferring dockerfile: 100B 0.0s
=> [internal] load .dockerignore 0.0s
=> => transferring context: 2B 0.0s
=> ERROR [internal] load metadata for 1.6s

[internal] load metadata for


1 | >>> FROM tryretool/backend:3.18
2 |
3 | CMD ./docker_scripts/

ERROR: failed to solve: tryretool/backend:3.18: : not found
ERROR: Service 'db-connector' failed to build : Build failed

Any idea why this happens?
Application worked before. i tried to update retool. after getting an error message, i tried to add the previous version 3.18 again in Dockerfile but now i can not make it run anymore.

Hi @mdmb , looks like you're missing the specification of the patch version for the tag.

I.e you've specified "3.18", but you'll need to supply a patch version i.e "3.18.24" for the latest patch version.

You can use Dockerhub as a source of truth to see which major/minor/patch versions are available!