Button in Table -- error on accessing url/opening webpage

Hi there!

I encountered this error while clicking a button in the table to open a new webpage:

The Table itself is populated from GSheets. Here's the column details:

Initially, I tried having a Mapped value of what I want to display on the button and thought that was causing the issue; nope, still got the same error.

Is this an error with {{self}} or the button type in table columns? Either way, I second this feature request where we can put event handlers to Table Action Buttons


Hi @jocen! Thanks for reaching out.

This is actually a bug we're working on :confused: I added a temporary bug fix to your org while we work on a more permanent fix. Can you check to see if it's working now?

It should work like this:

Animated GIF

Hi Tess, Happy New Year!

Did a quick test and yes, I can use self to directly access the url. Keep me posted on the update for the bug. Thanks!

Hi @jocen! We pushed a fix for this bug (and removed the temporary fix). There shouldn't be any changes on your end, but I wanted to check in just in case to make sure the table is working as expected.

Let me know if you notice any unexpected behavior and I'll loop in our engineers asap.

Hi @Tess, yes. Confirmed this to Everett on the intercom (was dealing with another issue that is connected). Thank you!

Oh, wonderful! Sorry I missed that

Thanks for pinging me too! :grin: