Workflow Shows Success on App Before Actually Finishing Running

Hello,

I've been building and testing a workflow designed to be triggered through a button click. Previously, when I click a button on the app, the workflow will keep saying "running WORKFLOW_NAME" with the running time until the workflow finishes running.

However, since a couple days ago, when I click the same button, the "running WORKFLOW_NAME" message only runs for less than 2 seconds, and according to the console, the workflow has finished running. But when I checked the workflow run history for the same run, it takes about 40-50 seconds to actually finish.


image

Can anyone shed some lights on what's causing this, and what's a solution for this?

The blocks involved in this workflow include some Retool AI, Snowflake select, Snowflake insert, and a webhook return.

Hi @brianzjj Thanks for reaching out! Our team investigated this issue & identified the bug. We are targeting getting the fix out this week :crossed_fingers:

If you have the time, we'd love to hear a bit more about your use of Retool AI :sunglasses: We are running an AI focused challenge this month (see more info here)!

Hi @Tess ,

Is this issue fixed? I just tried it and it's still not working properly.

Hi there,

Thanks for flagging! Apologies for the delay! It looks like this will go out in Retool v3.36.0, which should ship on Wednesday


Hello @Tess ,

Is the fix live yet?

Yes it is! Let me know if you're still seeing any issues

Hi @Tess ,

Yes, unfortunately I am still seeing the same issue.

image
image

Hi @Tess ,

Bringing this up again as this issue is our major roadblock in presenting this POC to our stakeholders. This also got me worried in the reliability of Retool as fixing a major component like Workflow would take so long. Is it possible for us to jump on a call so we can investigate which part has gone wrong?

Hi @brianzjj thanks for checking in & sharing how this is impacting your team. There was a bug fix for a related issue that went out on v3.36.0, but it sounds like this must be a separate issue.

The return block should ensure the workflow is run synchronously from the app :thinking: Could you share an export of the workflow so that I can investigate further with our team? or, if you can't share an export with us, post screenshots of the return block & app trigger?

I'm not able to set up a 1:1 call, but if we haven't sorted it out by tomorrow, I'd like to take a look in office hours if you're available to join

Export to JSON from top right corner:

Hi @Tess ,

The trigger setup in Worflow:

The trigger from the app is through a button click, which triggers a Google DocumentAI API through a REST API:
image

Then in the Event Handler, it returns the text extracted, which on success triggers a JS query to modify the data so it can be fed into the workflow:
image

The workflow query is set up as below, which on success would show a notification:

The final blocks of the workflow:

Again, thank you very much for looking into this!

Thanks so much! :thinking: I recreated a very similar flow in my own Retool org, but I have not been able to reproduce this yet :disappointed: I'm also not finding other reports of this issue, so I'll need to get more information in order to get a fix. Can you confirm what version # you're on (click on the question mark in the bottom right corner of any app)?

Long shot, but any chance the latest deployed version of the workflow doesn't have the webhook return connected to your workflow?

It seems like discussing this in office hours or sending us a JSON export would be helpful as a next step.

We were able to get a similar example internally & have flagged it to our team, so we'll keep you posted!

Any chance you see a different behavior when triggering the workflow from a rest query instead of the Import Workflow integration?