Table Data is not updated after filtering


I have a table and a search component to filter that table by id or name. I added to the search component a Change event handler to control that table. Added filterStackType "or" and filters:

{{[{columnName:"title", operator:"contains", filterValue: searchTrainings.value},
{columnName:"id", operator:"contains", filterValue: searchTrainings.value}]}}

The search works fine until I clear the search component from any search terms. The table no longer displays the original records, even though the records exist in its data. So not sure how to fix that.

Hi @hajarNasr, thanks for surfacing this! We'll follow up here when there's an update on this bug.

In the meantime, can you try setting your event handler to run only when the search input actually has a value and then create a separate event handler for when it doesn't? That second event handler would look something like this:

Hi @Kabirdas,

I'm not sure if there's been any progress on this bug, but I just ran into it. Luckily this post and your suggestion came up when I was searching for a solution.

In one app that I'm using a MySQL resource, I ran into this issue. Your workaround solved the problem and resulted in the table showing all the original data as expected.

In a separate app under a different company's account that I also work for, using the filter on a table with Google Sheets content, clearing the filter works as expected without having to use your workaround. I'm not sure if this is helpful, or if time is being spent on fixing this bug, but I wanted to share my experience.

Thanks for your help,

1 Like

Hey @chris_sws!

Thanks for the update here. There are currently some broader-scale table upgrades being worked on and they include filter upgrades! Keep an eye peeled for their release later this year :slightly_smiling_face: