Table component missing columns


I'm trying out the new table component. I have realised that I need a Primary key in order to use the Save feature with the changesetxxx properties. However, my primary key column/field (ObcjectOnAccountID - forgive the spelling mistake, I've carried it through everywhere!) isn't in the list. I previously hid columns I didn't want visible. In fact there are several columns missing from the list (of both available columns or available Primary keys). Two of the columns/fields are shown as hidden but other "hidden" columns are not shown at all. I tried the Refresh columns button but to no avail. The data property of the table shows all the columns.

I may try taking the data source out and then putting it back in, hoping I don't have to reapply ALL the column setttings again.



So, I had to clear the columns and then re-generate the columns - this worked.

However, I have reapplied all my column settings and (following one "crash" - out of memory I think, after 3 changes to the table settings). I have previously hidden columns are again, not selectable in the list. I remembered to choose a Primary key before I started hiding columns and now the column isn't in the list of primary keys either and I have a50af as the Primary key (assuming this is a hex reference to the column).

I also can't seem to find the changesetArray property, only the changesetObject which seems like it's going to be hard to use?

Hi there, thanks for your post! I'm glad that regenerating columns was able to help bring you back to a more accurate state with your columns. I'll pass along your feedback to the team.

It seems like the primary key column that you had selected (ObcjectOnAccountID) no longer exists in the table, which would also explain why the changesetArray property is no longer available. Could you try to "Add a new column" with ObcjectOnAccountID as the source ID, and re-selecting that as your primary key column in the table?

This should also help expose options such as changesetArray that are only available if the table has a Primary Key.

add primary key

Thanks @AnnaW ,

I read your reply without seeing the animation, but I was able to make it work and I can see how I can get back columns that have been hidden.

Thanks again