Primary Key not showing

The new table component correctly identifies my primary key as id

However, when I try to upsert via primary key, the drop down menu to designate a primary key shows all columns except id

is this intended behavior? and if so, how do I upsert

As a workaround I tried duplicating the primary key in an existing column already in the dropdown called source

However, this strategy failed , because sql perceived I was inserting rather than updating and thus violating the uniqueness constraint. Probably related to the problem above

Things tried: re creating the app from scratch

Hi @lee_walter!

The dropdown should have all columns. Does your table have the id column in the database or is the id column a custom column in Retool?

|interestingly, the column shows up now (a few days later) . i changed the schema to add the primary key, table 2.0 detected it almost immediately but possibly the resource controlling the dropdown took a few days to propagate. Thanks so much @victoria

Amazing, very glad to hear it :slight_smile: Thank you for the update!