Strange error on resources from a module


I have a few queries exported as outputs in a module.
Now I'm receiving a strange error like:
Unable to retrieve information about the query "moduleName::outputName".

Any advice?

Hi again,

I've tried to solve the problem moving the queries back to the main application but now I am receiving this message:
"Unable to retrieve information about the query ..."
It appears when I call on the query the invalidateCache() and trigger()
In the console there is no trace of the message, it only appears as a notification on failure

I can't understand the source of the error, can you please help me?
What can I try to investigate the issue?


Hey @Gianluca_Mereu!

Would you mind posting screenshots of the error along with the query itself and where it's being triggered? Happy to take a look and suggest things to try if I notice anything :slightly_smiling_face:

Hi, I got the same error message with a resource (query) when I run it I get the message and if I reload the page the query disappears.

Hey @maria.ramirez!

It sounds like there may have been a connection issue that cause the query to fail to save properly when you created it :thinking: Most queries aren't actually run directly from your browser, instead Retool saves the configuration in its backend and you send a request to run the query from there. So, for some reason or another, query28 never made it to be saved there.

That's just my guess though! Are you noticing this happening regularly? Do you happen to see any additional error messages in the networking tab of your browser's dev tools around the time that it does?


I also had this message showing, solved by merging my branch to main. I don't know if that was the case for the other scenarios.

1 Like