Self-hosted: Failed to enroll with Temporal

Hey there,

I just set-up self-hosted retool on a EC2 Ubuntu instance. After successfully launching it, I tried to enrol in workflows but get this error when clicking on enroll:
"Failed to enroll to Temporal Cloud. Contact support"

The error on show this error: {"success":false,"message":"Authentication failure. Missing xsrf token"}.

Tried 3.30.2 and 3.33.2-stable
Organisation: I run a cloud version and now also a self-hosted version. (Could that be the issue?)

egress works and is configured as requested. I'm also an admin in my organisation.

I tried to set an SSL certificate with
That didn't change anything for this error.

Thank you for your help.

I also set the retool licence key correctly.

Things I tried already:

  • created a new ec2 and set-up retool again. Same result.
  • created a new retool self-hosted account. Same result.
  • used a different browser. Same result.

Hey @jpmin! Retool Managed Temporal is only available on enterprise plans. From your screenshot it looks like that's what you are trying to set up? But let me know if that's not the case. We've got a table for viewing Temporal options here.