Schema migration failed

  • Goal: I'm trying to migrate my prod retool db schema to staging

  • Steps: Click on Schema migration menu, new migration,select everything, click on Confirm syncing

  • Details: I have an issue with enum type

  • Screenshots:
    I migrated enum type with success

But can't migrate tables schemas, it said enum type does not exist...

Tried many things since yesterday, I'm stuck not being able to sync my schema from prod to staging (I developped directly in prod with free version and since I switched to team subscription I want to leverage staging env and branches).

I'm still stuck, I would really appreciate some help or response from Retool :slight_smile:
I paid for team plan to have access to Staging env, but can't use it.... is there an official ticketing/support process ?

Hey @Nicolas_Le_Jeune, I'm able to reproduce the issue and am getting a bug report over to the engineering team responsible for Retool DB. We'll update you here as there is any new information to share on the status.

I believe that this is related to the way Postgres handles casing. In the interim, can you create new enums that are all lower case? This works on my end.

1 Like

Thank you Joe, I modified enum namein my schema in prod to remove capital letters and _ symbol. It works now so you where right, it's a bug.

Thank you so much for unblocking me !!!!

1 Like