Retool Embedding not working due to JS error

Hi everyone!

I’m trying to embed a retool app on another site.

In order to eliminate causes, I

  • made sure the app is public
  • followed the documentation to the letter
  • tried both the suggested example in the docs and iframe embed via the “share” button
  • made sure I can see the retool page in incognito
  • put the code onto a production website with https
  • tried with multiple apps, including a super simple one

Still, no matter what I try, I always get

Uncaught TypeError: Cannot read property 'checklistCollapsed' of null

in the console.

It seems to me the underlying JS in the iframe is broken.

Would anyone be able to help please?

Hi @MarkRosemaker! Welcome to the community! :sunglasses:

Are you seeing this error on all browser types? Is it possible that the browser settings are restricting the embedded window? I’ve seen this error when Brave browsers default settings were restricting an embedded Retool application.

That was it! Thank you so much!