Error in embedding google data studio to iframe

I have been trying to embed data studio into the iframe component in the app builder but so far I am running into this error: "Could not connect to the reCAPTCHA service. Please check your internet connection and reload to get a reCAPTCHA challenge." I have tried embedding data studio elsewhere and it is working fine. Is there any work around this or what can I do to resolve the issue?

@Aristotle Welcome to the forum!

When you say you have embedded it elsewhere, do you mean within the same app? Or another Retool app? Are you running on the Retool cloud platform or is Retool on prem?

When I mean elsewhere. Either on another platform such as wordpress not retool related. I did this to determine whether the embed function of data studio was working or not. I am running it on the retool cloud platform.

Hey @Aristotle, can confirm this is happening to me as well. I've used to be able to use just the reporting url to show it in the iFrame. but I got an error like this:

I tried using the embed URL and it showed me the reCAPTCHA service but this was the entire error I got:

Needs to be raised to Retool peeps to be classified as a bug.

I am not sure if this is a bug if there is any sort of authentication between the source and Retool required - for example, when attempting to use a signed URL from S3, it will not load because S3 doesn't recognize that the iFrame is a part of Retool - if that makes sense - at least this has been my experience - but will have to see what the Retool team says

Access permission to the urls I've used are already open to public access, forgot to add that above. So yeah, not sure if there's any authentication needed for that end.

Hi @Aristotle and @jocen - Retool Support here happy to help!

Can you confirm if you're following the instruction here for Embedding via HTML iframe and not Embeding in the new Google Sites? re:

Hi @Jay, was using oEmbed in the iFrame component on my previous examples.
I tried using HTML component but that didn't show me anything. Tried removing the div it is under in and just retain the iFrame tag but that didn't show me anything as well.

Hi @Jay I did the same thing as @jocen. Tried both embedding using the iFrame component and HTML but nothing pops up. Although for the iFrame component a recaptcha error pops up. Here is what it looks like. Just so you know I have embedded data studio in other sites as well including such as wordpress and other websites and the url link is already publicly opened. Unless we are missing a step in retool, it would be helpful if you could break it down for us.

Hey all!

Trying to embed google data studio generated the following message in my browser console:

This seems to have been fixed by enabling "Storage and cookies" on the Retool iFrame component:

Can you let me know if that works for yall as well?

1 Like

hi guys, this is not working for me, even simple page:

any idea?

Hey @barak.meiri!

Some websites restrict where they can be embedded via the frame-ancestors content security policy. It looks like linkedin can't be embedded in other sites:

They do support embedding specific posts from your feed but to embed the entirety of your feed you may need to use a 3rd-party service.

It did the trick for me. Thanks!