Range slider start value is blocked

Hey everyone!
I'm having an interesting problem with the range slider component, after adding it to my app and refreshing the page, the component is rendered with the default values but does not show it, after trying to change the blocked sliders for the first time, the values become NaN, as you can see on the gif below:
PS: I tried changing the values with a switch, forcing the component to re-render and it ended up working.


I have also tested in other apps and it has the same behavior.


Hi Guilherme! I see it broken on page load as well. The values that come with the component when first dragged into the app seem to work just fine (bottom slider).

I'll dig more into this and create a bug report once I'm able to pinpoint more of the issue!

1 Like

Hello Victoria, thanks for the help :slightly_smiling_face:

I've made a workaround here to make it work by running a script when the component changes, checking if the initial value is NaN.

For those interested, here it is:

const component = rangeSlider1
if (Number.isNaN(component.value.start)) {
    component.setValue({ ...component.value, start: 1 })

That is so clever! Thank you for sharing that until we get this bug fixed :)

1 Like

Hi again @GuiVP! This should be fixed now 😊 How is it looking on your end?

Thanks a bunch for writing in about this, for all the details which made it easy for us to reproduce and for your patience while we worked on it!

Hey @victoria! Yeah, everything is good now.
Thanks for the attention, I appreciate it. :grinning_face_with_smiling_eyes: