Quota limits for OpenAI AI Action block in workflows or apps

On Wednesday last week, my AI block (connected to my OpenAI API) in my workflow stopped running. This was the error message:
{"data":{"error":"You exceeded your current quota, please check your plan and billing details."},"metadata":{"success":false}}

At that point, my OpenAI API was limited to $120 per month. I checked OpenAI and saw my API usage was $126 - so this seemed like a logical thing to happen.

On Thursday, OpenAI increased my monthly quota to $2,000. However, I still got the same error: exceeded quota message. Thus, I couldn't get the workflow to run and finish generating the categories for the entire dataset.

I've come back a week later and found that the AI Action block runs (although I have only used $10 today, whereas last week I used $70 in 1 day—not sure if daily use is relevant).

However, the OpenAI API, accessed through a Resource is now giving me the same error. I am using the API through the resource to access their transcription tool - Whisper. A screenshot of this is attached.

Looking for feedback or guidelines on how the quotas work and if there are ways to solve!

(I know the value in 'file' in the resource block is incorrect - still figuring out how to reference correctly)

Screenshot 2023-10-26 at 12.36.07

Hey Tim! Just to double check, you using your personal OpenAI API key or a Retool-provided hosted key?

Hey Victoria! It's my personal OpenAI API key.

Got it! It looks like you may need to generate a new API key (on the OpenAI side) after you increased your quota. Could you try generating a new API key, entering it into Retool and seeing if that works? :slight_smile: