Query editor cause "cannot read properties of undefined" error

Hi there,

I am using Retool on premise. I found this issue recently.

When I create or open an existing query, the moment I typed any thing in the editor, the error "Cannot read properties of undefined (reading 'length')" will occur, and editor will not work properly (no code completion, cannot delete using backspace). But the query still works.

This is happening to all my apps, tried upgrading from 2.107 to 2.108.11, still the same.

Any ideas? Thanks so much.


Hey @Charles_Liu, Following up from Retool's Support team. Could you share what browser and operating system you're seeing this on? Additionally would you be able to share an export of an app where you're seeing this issue?

Hi @everett_smith , thank you so much for the reply.

I am using Chrome 110.0.5481.177, on Windows 10 Pro 21H2

Here is an exported app from my system, I just created it and there is one simple js query in it, still having that error.

Seems I am not allowed to upload file, so here is the link.

Found the reason,

I installed Chrome extension "Google Input Tools", and when the extension is enabled, this issue will happen.

Sorry my fault :sweat_smile:

Oh, excellent news :raised_hands: Nicely done troubleshooting on your end and thanks for sharing the cause!