Data Source autocomplete does not work anymore and shows is not defined


no idea what is going on but I am not getting any autocomplete of queries anymore in between my {{ }}

Anybody know how I can fix that? Quite annoying

1 Like

So do I... No autocomplete anymore :frowning:

Hey @Sander @Edjevw12! Taking a look at this. Mind sharing where you are seeing this? Tried this in the Data source field of a table and inside of a postgres query and it seems to work. But happy to dig further and find out where this is not working for you. Any screenshots etc of where you are seeing this would be great, thanks!

All components are not defined, so no autocomplete, and it doesn't matter where (so queries, components, etc.)

@Edjevw12 Is this happening consistently, or intermittently? Also to clarify, is this on Retool cloud or a self hosted instance?

Same here. For me it happens consistently. Only worked at start of app when I just created app and started to add components/queries. Then, after release and a couple of edits, autocomplete stopped to work. All components are "'table1' is not defined".
Very annoying.
On self-hosted retool instance.

Sorry to hear that @Pataposha, which self hosted version are you currently using?

Retool version 3.20.0

Thanks @Pataposha, that's the Retool Cloud version. I'll note that on the internal ticket.

Same here, code completion is not working in editors (screenshot attached) . We are currently on selfhosted v3.18.6

I am also experiencing this issue. It is consistent and occurs in queries and components, when attempting to reference queries, components or available JS properties. We are on Retool version 3.25.0.