One of the two identical workflows does not work

A while ago, I made a workflow for a daily import of vehicle data. The workflow gets the data from a REST GET endpoint and bulk upsert it to a retool database table. This worked for like a month and suddenly, it broke. Unfortunately, the logging is not yet perfect to know where the problem was. So, I tried some work around like splitting the data into sliced arrays or record for record upserts, but nothing worked. My last resort was making a new workflow, and this was working instantly.

Could it be possible that, for that particular workflow, something started leaking memory? If that is the case, that seems like a serious thing to look into.

Hey @Kalli_van_den_Heuvel!

The dev team has been looking into it and it looks like one of the function blocks in the broken workflow had a large dataset as the default value for one of its parameters:

This made the size of the workflow itself too large for the backend to handle and started triggering failures.

There could definitely be better error logging here and they're looking at surfacing more information to people about workflow runs. Thanks for surfacing this as it is great feedback!

1 Like