Navigation component is not showing on public link

Please help me see why my public version does not show the navigation pills

However, when I view this same page in the preview mode, it is there

I really need this to work for my coming demo. Thanks!!!

I switch to using tabs as a workaround. Navigation simply doesn't show up for me. I checked the DOM elements for navigation and it is empty.

Turns out Tab element does not support handle click event on each tab, but rather to switch between views.

I found the solution, make sure to use type "custom" for navigation; otherwise, the navigation won't show.

Hi @anpham! Thanks for sharing the current workaround!

This is a public apps bug that our team will fix. I'll post here when we've shipped the fix :slightly_smiling_face:

Hi @Tess , the Navigation Buttons still won't show on my Public page. Any updates on this issue? Thanks!

Hi @anpham! Where can i actually find the "custom" tab? I don't see in anywhere on my navigation inspect

Hi @ten! If you Click on a specific menu item (ex. KPI), there should be an option for custom.

If you don't see it or it doesn't work, can you let us know which version of Retool you're on? It should be in the bottom right corner of your screen when you click on the question mark button

1 Like

@Tess Found it, thank you! but i still need the 'App' type to be working on the public link as well. Please let me know as soon it is fixed :slight_smile: with custom, i have to input the password every time i clicked on the other page.


any updates on this issue? ^^

Hi @ten Thanks for checking in! I don't have an update on this one yet :disappointed: It's still in our queue. I'd recommend continuing to use the custom workaround for the time being

+1 having the same issue, please update me when fixed!


+1 on this issue.


Also note that if you have multiple navigational components in an app - you'd get a bug where the newly added navigational components would partially be hidden - making them unusable.

Is this problem still not solved?

Our team is still looking into it! I just checked in with them internally, so I'll post here if we have any updates we can share


This should be fixed next week Wednesday! :blush: